0
Answered

WAMIKey not populating via IdB Aurion connector

Ryan Crossingham 6 years ago in UNIFYBroker/Aurion • updated by anonymous 4 years ago 2

I am currently experiencing the same issue mentioned in ACMA-11 - WAMIKey not populating via IdB Aurion connector and now receiving "Aurion API error -1: Employee No not found in Aurion" which i did not believe was required for security users

From the looks of this issue it indicates that some changes were performed in order to get this working. Can we confirm these changes have followed on the 4.1 release?

I'm 99% sure my configuration is spot on..
I've spent a lot of time modifying this and trying different things to no avail.

Any help would be appreciated as this is currently holding up my production go-live

Please see configuration attached below

Unify.Product.IdentityBroker.ConnectorEnginePlugInKey.extensibility.config
<connectorconfiguration>
      <connector id="34bfc0b6-1dd1-4254-80b0-53932487d505" connector="Unify.Connectors.Aurion.SecurityUser" name="Aurion Security Users" queueMissed="false" enabled="true" auditLevel="None">
        <entitySchema>
          <field name="User" key="true" readonly="true" required="true" validator="string" id="925ce35d-f275-4dd6-a115-d03b58d00b5d">
            <Extended xmlns="" />
          </field>
          <field name="OsUserId" key="false" readonly="false" required="false" validator="string" id="9016c684-2a1c-4471-bdec-4f4d916ea191">
            <Extended xmlns="" />
          </field>
          <field name="Name" key="false" readonly="false" required="false" validator="string" id="8dddc336-e7bd-443f-9707-d0b83ee88a64">
            <Extended xmlns="" />
          </field>
          <field name="WamiKey" key="false" readonly="false" required="false" validator="string" id="66c5aa11-eb9b-4e90-ab5b-0612bbdc428c">
            <Extended xmlns="" />
          </field>
          <field name="Status" key="false" readonly="false" required="false" validator="string" id="e0d63812-ebcc-4ef9-90dd-16081cade845">
            <Extended xmlns="" />
          </field>
          <field name="Password" key="false" readonly="false" required="false" validator="string" id="c998cf42-49f5-4206-aaf8-6a9e91e7d812">
            <Extended xmlns="" />
          </field>
          <field name="PasswordExpired" key="false" readonly="false" required="false" validator="boolean" id="1c1cabfd-2efb-4720-84c7-e8ba0fd09c6b">
            <Extended xmlns="" />
          </field>
          <field name="ExternalMailType" key="false" readonly="false" required="false" validator="string" id="a177f794-2395-461b-b2f7-03a22afdf7ab">
            <Extended xmlns="" />
          </field>
          <field name="EmailAddress" key="false" readonly="false" required="false" validator="string" id="a98935fc-b53d-4122-be9e-68e72a76324b">
            <Extended xmlns="" />
          </field>
          <field name="MessageGroupCode" key="false" readonly="false" required="false" validator="string" id="a4d1b16e-dbd9-453b-9ef9-fa206aac4f99">
            <Extended xmlns="" />
          </field>
        </entitySchema>
        <Extended>
          <apiSchema name="AQT_Output">
            <queries>
              <query queryId="LIFEHOUSESECUSER" />
            </queries>
            <attribute name="User_Id" target="User" />
            <attribute name="OS_User_Id" target="OsUserId" />
            <attribute name="User_Name" target="Name" />
            <attribute name="Person_Number" target="WamiKey" />
            <attribute name="User_Status" target="Status" />
            <attribute name="User_Password" target="Password" />
            <attribute name="Password_Expired_Flag" target="PasswordExpired" />
            <attribute name="Email_Address" target="EmailAddress" />
          </apiSchema>
        </Extended>
        <Groups />
        <Agents>
          <Agent id="fc40e36f-7431-4d7f-9654-ae1e34a4727f" type="Unify.Agent.Aurion" />
        </Agents>
      </connector>
      <getAllEntities />
      <polling />
    </connectorconfiguration>
Unify.Product.IdentityBroker.AdapterEnginePlugInKey.extensibility.config
<AdapterConfiguration AdapterId="aeeff3fe-ea0a-4326-8f65-291419d2c66e" AdapterName="Aurion Sec Users" enabled="true" BaseConnectorId="34bfc0b6-1dd1-4254-80b0-53932487d505" class="sec_user" AdapterImportSettings="CoupledProcess">
      <dn template="CN=[User]" />
      <Groups />
    </AdapterConfiguration>
Affected Versions:
Fixed by Version:

Hi Ryan,

Is this on add?

Looking at your schema mappings I can see you're putting the PersonNumber value in the WamiKey field. It should actually be EmployeeNo, that's probably why it's saying it can't find a corresponding user.

Where'd you get your config, did you bring it over from v3.x? The v4.1 SecUser schema provider shouldn't be creating anything called WamiKey and there shouldn't be any reference to it in the product or documentation, as far as I know it's a terrible term that has no meaning outside of client who the connector was originally written for.

Also worth noting the EmployeeNo field on the API is only specified on adds, not updates; the reason for this is explained ACMA-11, basically there's a "feature" (or bug, I haven't bothered to ask) that prevents you from updating this value after initial creation anyway.

Hi Ryan,

Closing this as I believe we resolved this over the phone, can you close if that's the case.