0
Duplicate

Full import returns only root node

Bob Bradley 9 months ago in UNIFYBroker/Microsoft Identity Manager updated 9 months ago 3

When running a FULL IMPORT on an IdB5.3.2 implentation I am getting data returned from only 2 of the 7 configured partitions - yet data is clearly visible for each of them via LDP, making me suspect an issue with the Broker for MIM component.  I have tried deleting and recreating run profiles, refreshing schema, reloading interfaces, and even creating a new instance of the MA - but still the same result.

There are no exceptions being logged for the full import (currently in VERBOSE mode).  As an example

  • The AREA adapter correctly returns 11 records, including the root container node (although the Total Entities count incorrectly shows as 0 on the Import job counter)
  • The COMPANIES adapter returns 1 record, being the container node only - despite all objects appearing correctly via LDAP.EXE.

Can I please have some urgent assistance to determine the root cause?

Affected Versions:
Fixed by Version:

This turns out to be a duplicate of https://voice.unifysolutions.net/communities/6/topics/3978-ou-case-renames-not-working raised 3 weeks ago and put in the backlog - if only I'd been able to find it and save 3-4 hours.

Workaround in the meantime: run the Clear Data SQL script that is installed with Broker to reset the Unify.IdentityBroker database and then run full imports on all connectors.