0
Answered

Server too busy

Matthew Woolnough 2 years ago • updated by anonymous 2 years ago 7

After leaving IdB for an extended period of time (overnight for example), the Web Interface shows an error. After updating <customErrors mode="Off" /> in the Web.config to display errors, the error displayed is "Server Too Busy" as shown in the screenshot below. 

No jobs are scheduled.

I believe this may be related to this previous issue, but not seeing the memory blow outs any more for some reason. 

Will attach logs & config shortly.







Affected Versions:
Fixed by Version:

Answer

Answer
Under review

Hi Matt,

After leaving IdB for an extended period of time

Do you mean that you left the browser open on one of the pages? Do you recall which page/s you left open?

I note that you are using the embedded web server option. Due to performance issues, we are deprecating the embedded web server as of Identity Broker v5.2. If the problem persists, I would suggest swapping to IIS - see Configuring Identity Broker for use with IIS for installation and configuration instructions.

Answer
Under review

Hi Matt,

After leaving IdB for an extended period of time

Do you mean that you left the browser open on one of the pages? Do you recall which page/s you left open?

I note that you are using the embedded web server option. Due to performance issues, we are deprecating the embedded web server as of Identity Broker v5.2. If the problem persists, I would suggest swapping to IIS - see Configuring Identity Broker for use with IIS for installation and configuration instructions.

There were 3 pages open.  One was adapters, another was a specific connector. Not sure about the third.

Is there a notice somewhere to say this is being deprecated?

I was not aware of this. I'll swap over to IIS a we're still in Dev. 

The documentation page for the embedded web server (http://voice.unifysolutions.net/topics/2942-configuring-identity-broker-for-use-with-embedded-web-server/) states that it's deprecated. We haven't done up the release notes for v5.2 (the first version that deprecates it) just yet but we'll also mention it there.

The following command can be used to install all the required pacakges: 


Install-WindowsFeature Web-WebServer,Web-Common-Http,Web-Default-Doc,Web-Dir-Browsing,Web-Http-Errors,Web-Static-Content,Web-Health,Web-Http-Logging,Web-Performance,Web-Stat-Compression,Web-Security,Web-Filtering,Web-Windows-Auth,Web-App-Dev,Web-Net-Ext45,Web-Asp-Net45,Web-CGI,Web-ISAPI-Ext,Web-ISAPI-Filter,Web-Mgmt-Tools,Web-Mgmt-Console
Under review

Thanks Matt, I'll add this as a comment to the documentation page.

Creation of Website for IdB can also be done like this.

Import-Module WebAdministration

New-Website -name "Identity Broker" -PhysicalPath "C:\Program Files\UNIFY Solutions\Identity Broker\StandaloneWeb" -ApplicationPool "DefaultAppPool" -force

Switching WindowAuth on is a bit more difficult & I'm not going to waste time on working this out right now.