Refresh MAs doesn't appear to be doing anything

Bob Bradley 3 years ago updated by Adam van Vliet (Chief Information Security Officer) 3 years ago 2

Hi.  Can someone please help me with information on the use of the Refresh MAs button shown in the second of the above screenshots?  I understand the intent of this button might be to resolve an issue I have presently where both the MA and Run Profile IDs specified in the <Extended> node of the operation extensibility file no longer seem to match the MIM IDs.  I was hoping that the button will help me reset these all to the correct values, but the button doesn't seem to be having any affect, and I can't find any documentation on the use of this button to confirm this is the intent.

Incidentally I've also tried using this feature when porting extensibility configuration from one MIM sync server to another where the MA and run profile names are the same but the guids different - however in this case both source and target MIM IDs are identical.  In Production the UNIFYNow configuration is working fine in the source environment, but it fails for ALL MA/Run Profile combinations in the target system with the following exception:

Operation faulted: Attempting to check for exports in non-existent management agent with id 6c582b25-f84e-4d85-830e-ab0e36bcd020 - Please see the log viewer for more details.


Thanks Adam - I worked it out yesterday evening but didn't know about the 4.0.4 fix (I got it going with 4.0.3 by resetting all the guids - see my comment just now on https://voice.unifysolutions.net/communities/5/topics/3566-non-existant-management-agents-after-upgrading-from-v3-to-v4).