0
Under review

Non-existant management agents after upgrading from v3 to v4

Carol Wapshere 2 weeks ago • updated 1 week ago 11

After upgrading EB from v3 to v4 all my operations stopped working with errors like "Attempting to check for exports in non-existant management agent". I refreshed the FIM Agent which did not help. I then created a new MIM Agent and went through manually updating every single check operation and run operation (there are *lots*) to reference the new agent. Dev then worked.

I have just upgraded Test and the same thing has happened, even though I migrated the OperationEnginePluginKey and AgentEnginePluginKey files from Dev (then fixed the agent database path through the UI). Again I've refreshed MAs, and restarted a few times, but everything is broken with "non-existant management agent" type messages.

The MA GUIDs are identical in both environments and I always update EB by copying the OperationEnginePluginKey file.

How can I fix this without having the edit every single operation again?

I dropped them in the Services folder and restarted the service, but no change. I also tried refreshing the MAs again but it didn't help.

Where does the managementAgentId in the Operations config file come from? It does not correspond to the MA GUID in MIM Sync so there must be a matching somewhere - but where?

Under review

Hey Carol,

In previous versions of EB, an improvement was made such that the MA and run profile id's were stored separately, keyed using a new id internal to EB - as a number of MIM solutions were not being properly migrated between Dev->Test->Prod, we were seeing the id's change.

The patches found above were written to resolve a potential bug in the upgrade process. 

Could you try the upgrade again and place the patches in before starting the service for the first time?


I can uninstall and reinstall but I can't upgrade again - no VM snapshot or anything like that.

How does one migrate the internally stored id mapping? Wouldn't that be the more sensible approach?

What is legacyKeyMode?

I have:

- Uninstalled EB from the Test server

- Cleared out the Extensibility folder

- Installed EB 4.0.1 (not starting service)

- Put those DLLs in the Service folder

- Copied the Agents and Operations config files from Dev to Test

- Started EB

- Fixed the Agents (which had Dev SQL server name in them) - all agents reporting fine

- Refreshed MAs

No change - everything still broken with the same error.


Hey Carol,

Can you double check that the DLL files you've placed in aren't zone blocked? (right click, unblock, apply).

Can you also please attach a copy of the following:

  • Extensibility files
  • Logs showing the errors you're having
  • EventBrokerStoredValues.xml file, located in isolated storage. 

The path to the StoredValues file will be similar to:

C:\ProgramData\IsolatedStorage\s5qxz2zq.wns\gzjiptql.dr4\Url.k53zrnx23fuyza4tycitlynapfpnwmoi\AssemFiles\EventBrokerStoredValues.xml

Could you please let me know the MIM id's for one of the MA's and associated run profiles? I might then be able to track down why it's not picking it up. Thanks.

I sent lots of files to Matt including the MIM Sync server exports from both Dev and Test, so all the info you need will be in there.

I got it working by copying that hidden EventBrokerStoredValues.xml file from Dev to Test - though I would class that as a workaround.

This happened again and I couldn't get my workaround to work this time - no idea why it worked in Test and not Prod. I have ended up having to manually go through and reset every operation again.