0
Fixed

Unable to Upgrade IdB v4.1.1 to v4.1.3

Monash 4 years ago • updated by anonymous 4 years ago 12

Hi

We are unable to upgrade from v4.1.1 to v4.1.3 of Identity Broker Service

Our server was on v4.1.1 RTM

1) First we had tried a "attempt upgrade" to v4.1.3. It failed with SQL error (attached screenshot)

2) Then we thought probably we need to go v4.1.2 first before.. So we downloaded "UNIFY Identity Broker Service v4.1.2 RC1 x64". Upgraded to that. Worked. Then tried v4.1.3 upgrade and failed again

Please let us know how to fix this asap

We do have a backup of v4.1.1 DB with us.

Regards


IdentityBroker Upgrade.sql
unifyidb.sql
Upgrade Error.JPG
Affected Versions:
Fixed by Version:

Just to clarify

The above steps were not done on the same DB or on the same server

The above error is from step 2 which we tried today

Step 1 was a month or two ago on another server with Rizwan but had ignored it at the time. But I believe it was the same error.

The issue is assigned to Adam for input or a work around. He is in a meeting until 1:00 PM, waiting for him to get back on this.

attached the schema file as requested

Monash is rolling back to v4.1.1 with restoring of database taken before the upgrade of v4.1.3.

However, Adam will looking into the issue reported with the help of the script provided.

Changing the status of issue from blocker.

Hi Monash, we have found the issue with the upgrade script and have fixed it up. Would you like me to make it available now, or are you happy to wait until it's released as part of Identity Broker v4.1.4?

Hi Adam

When you reckon 4.1.4 will come out? If by next week then yes we can wait for that assuming no issues upgrading 4.1.1 -> 4.1.3 and4.1.1 -> 4.1.4

Else you can drop a v4.1.3 for us

We have got around our dev timing by doing a clean 4.1.3 install

we do have some other servers on 4.1.1 but we would like to upgrade next time to v4.1.3 / v4.1.4 instead of clean

Thanks for the quick response

Testing for v4.1.4 should be next week. But in case it's pushed back for some reason, or you need the script earlier, please see the attached script that has been fixed up IdentityBroker Upgrade.sql.

Thanks

So we run this on the IdB DB?

And then do the 4.1.3 exe install with manual install option?? or attempt upgrade option?

In the end it would be best to wait for the full proper build ..

The options would be to install v4.1.3 using the manual database option, then run the IdentityBroker Upgrade.sql script; or wait until v4.1.4, and use the upgrade database option.

Thanks.

Based on my conversation with Piyush. DEV-5 is now on IdB v 4.1.3 but this was achieved with a fresh install and not an upgrade on 4.1.1. I believe Monash is not very keen to apply the script provided in this ticket, however this script can be integrated to IdB v4.1.4 to support a smooth upgrade from v4.1.1 to v4.1.4.

I will mark this issue resolved based on the fact that DEV-5 is on v4.1.3.

Adam may close the issue once IdB 4.1.4 is released.

Issue can be reopened if the release v.4.1.4 fails.