0
Fixed

Reverse DN Converter transform silently ignores value deletion

Adrian Corston 5 months ago in UNIFYBroker Service updated 4 months ago 7

I have an adapter with the following transform:

This transform works as expected in both directions, but when an update comes from the LDAP gateway to delete the DN value that LDAP request is successful, but the old values for the DN (SubsectionDN) and the source attribute (Subsection) are retained.

Affected Versions:
Fixed by Version:

Matt is on leave this week but made this (untested) suggestion:

"A workaround might be to have a powershell transformation after this one, which simply copies the value from one schema field to another. So mim will just read it from a different field. But on write back, you can have the reverse powershell transformation delete the original value which should resolve it as a temp fix"

I tried Matt's workaround and it appears to have been successful (from LDP.exe).  I will exercise it more (from MIM) to make sure.

Unfortunately this won't work from MIM at the moment, because the PowerShell transform marks its adapter fields as read-only, and the MIM ECMA2 DLL therefore won't let them be an export destination.

Hi Beau, we're trying it now.  It's taking a while to get sorted.

Hi Beau,

The patch worked for several ad-hoc tests.  I'm working with Bob to see if we can exercise it more fully, but provisionally it's looking great.  Thank you very much!

The customer went live with this patch in their Production environment and I haven't heard of any issues.  If/when this fix is merged into the main UNIFYBroker product please let me know so I can see about upgrading them.  Thanks!