Adapter with a Foreign Multivalue Group can't be enabled and no schema rows show in the UI

Adrian Corston 4 years ago in UNIFYBroker SDK and UNIFYCore updated by Bob Bradley 4 years ago 9

I added a Foreign Multivalue Group transform to an Adapter and the schema rows no longer showed.  When I then enabled the Adapter an error appeared: "Object reference not set to an instance of an object at Unify.Product.IdentityBroker.TemplateDistinguishedNameParser.ParseTemplate".

Connector "Owners":

Image 5725

Connector "Things":

Image 5726


Image 5727

Image 5728

Here is the transform (against the Owners connector):

Image 5724

When I attempt to enable the Adapter this error appears:

Image 5729

If I remove the Transform then the Adapter's schema re-appears:

Image 5730

If I attempt to edit the Transform an error appears:

Image 5731

Logs & Extensibility attached to next comment.

Satisfaction mark by Adrian Corston 4 years ago
Under review

Hi Adrian,

Can you please give this patch a go to see if it resolves your issue?


Place the file in the /Services/ directory and restart the service.

Do not use this patch anywhere else - it introduces another bug where the Distinguished Name Converter generates adapter properties that are read-only when they shouldn't be.  Look instead for a more recent patch of the same DLL.

Link to the preferred patch?

Is this the case wherein the adapter properties appear to be read-only in the schema (so MIM thinks you can't write to them) but it turns out that if you actually write to it (e.g. via LDAP) the (newish) reverse translation feature does the right thing regardless?

Not sure but reinstating the existing CASA dll patch changed the schema back to readonly = false ... I only tried the patch because I couldn’t get multivalve foreign join working before I realized I needed a normal group transform


Hi Bob,

This is incorrect. I can confirm that this is a separate issue, which occurs in a fresh v5.3.2 release installation without that patch installed. It was fixed not that long after the patch for this issue was created, however (not in relation to any Voice ticket). Could you have accidentally overwritten a newer version of Unify.IdentityBroker.Adapter.EntityTransformation.dll provided as a patch on a different, more recent issue?

Thanks Beau - I hadn't overwritten a previous patch, but rather renamed one and tried the one attached to this ticket in an attempt to fix something else (which turned out to be user error).  The file date on the existing Unify.IdentityBroker.Adapter.EntityTransformation.dll patch is 21/4/2020 ... but I know I can't go by that (both DLLs say file version  Anyhow, I've reinstated the original one and the temporary "read only" issue is no longer present.

Hi Matt,

Thanks for this - it worked perfectly!


Hi Matt,
Could you please make sure this patch is included in the next UNIFYBroker release?
I'm working on a new customer development and needed to re-use this patch with the latest version of UNIFYBroker (5.3.2).