0
Fixed

Adapter not calculating changes

Hayden Gray 4 weeks ago updated 3 days ago 6

Hi Guys,


I've been on a few calls recently with a client where they are report delta imports not working on their Aurion Personnel management agent in FIM. I have jumped in their environment and had a look and did the following steps to troubleshoot the issue:

IdB and FIM troubleshooting

* Got client to make changes in Aurion

* Ran an Import all on IdB connector to bring in change

* Ran Delta Import on Aurion Personnel MA . MA runs successfully with no error. Also no error present in IdB logs

* Ran a Full Import and change flows in as expected.

* Tried increasing the operation timeout on the MA run profile and still runs as success with no changes.

* Tried manually generating changed entities on the adapter and running a delta import and still no changes.

DB troubleshooting

* Viewed change log table and was able to see changed record for the Adapter in the log

* Viewed the changes table for the Adapter and was not able to see the change.

* Checked entity table for duplicates and no duplicates present for the Adapter.

This issue is only present on this particular MA and as mentioned produces no errors. It almost seems like IdB is do generating changes correct on the Adapter. Please see below the details for the environment and the see the comments for support documents.

UNIFYBroker: 5.3.1

Aurion Connector: 5.3.0

SQL: 2014

Let me know if you need any further information.

Thanks

Affected Versions:
Fixed by Version:
Under review

Hey Hayden,

Could you please provide some timestamps on when you ran the tests - the import from Aurion, then the delta import from MIM to Broker and also the full import from MIM to Broker. This will help us narrow down the logs.

Also, if you could use a tool such as Rawcap to gather a network trace of the delta import request from MIM, we can validate the changeset its requesting.

Hi Matthew,

I've just had another meeting with the client and was able to use Wireshark to capture the data. Hopefully this is ok for you guys to work with. I simply used a filter to capture all local LDAP traffic as both FIM and Broker are installed on the same local host. I will also provide screenshot of the change record in the change log.

If I missed anything or didn't capture the right traffic with Wireshark just let me know.

Thanks

Hi Beau,

Sorry for no reply lately we were having issue getting the files. I'll paste the requested zipped files below.

Thanks

Thanks Hayden,

MA in usage was the patch provided by Curtis in the past. Here is an updated MA which corrects this. To install:

  1. Replace existing dll
  2. Edit the properties of the Broker MA and refresh interfaces on the Select Extension DLL screen.
  3. Advance to the Connectivity screen and set the Watermark file directory to the full path of a directory that watermark files will be written to. The user MIM runs as will need to have read/write/modify access to this directory.
  4. Full import the MA

Once installed, imports will write a watermark files to the configured directory, with a watermark file for each run profile step. Watermark files are named based on a unique internal MIM id, but the only human readable identifier available is the DN the run step is configured to, which is part of the file content. Because of this, I'd recommend that each MA to be configured to write watermark files to a different directories if you have many MAs that import from the same OU.

Unify.IdentityBroker.FIMAdapter.dll

Thanks very much Beau, I'll organise a time with the client next week to put it in, I'll let you know how it goes.

Thanks

Fixed

Had a meeting with the client today and put the patch in. Everything is working now, and I can see the watermarks are being split up in that OU.

Thank you very much