0
Answered

IDB Upgrade Problem - Service no start

Daniel Walters 3 weeks ago • updated by Beau Harrison 3 weeks ago 10

I'm upgrading Identity Broker to UnifyBroker for a customer and the service isn't starting. No errors show up in Event Viewer and after attempting to start the service, the service status sits at "Starting" and nothing else can be done with it until a restart. There's nothing in the Identity Broker logs folder. Any clues as to where to look next?

Affected Versions:
Fixed by Version:

Answer

Answer

That is the wrong version connector. The major and minor versions (first two numbers) of a connector must match the version of Broker your installing them into.

Under review

Hi Daniel

If you open the Extensibility\Unify.Framework.Logging.LoggingEnginePlugInKey.extensibility.config.xml file and change minimumLoggingLevel="Normal" to minimumLoggingLevel="Verbose" additional logging will be output which may include something helpful.

You could also try running the Broker debug executable, Unify.Service.Connect.Debug.exe which starts Broker in a console application. Ensure the Broker service is stopped and run the exe as administrator.

It was at diagnostic by default, is that a move versbose logging than verbose?

They had version 4.1.1 and I'm upgrading to 5.3.1.3. The steps I took are

  • Stopped the idb service
  • installed .net 4.5.1
  • rebooted server
  • uninstalled existing connectors then the idb service
  • renamed the installation folder
  • installed Broker5 and the new versions of the connectors selecting manual install
  • Upgraded the database with the script (db is on another server)
  • updated the data engine extensibility file to point at the remote server
  • left the rest of the default extensibility files and attempted to start the service
  • Service doesn't start and there is nothing in event viewer and no logs that I know of to check.

I've found that the service starts if the Chris21 connector is NOT installed and does not start if the Chris21 connector is installed. The Chris21 Connector I'm installing is v5.1.0 RTM.

Answer

That is the wrong version connector. The major and minor versions (first two numbers) of a connector must match the version of Broker your installing them into.

Thanks, got past that. I now have a problem when I copy in the old extensibility files. Pre-upgrade, there was an Aderant Expert agent installed. I've uninstalled it now and they actually use SQL for the aderant connection now. But when I attempt to start the service it complains about some reference to the no longer installed aderant agent. Do you know where this reference would likely be in the extensibility? There isn't a reference in the adapter engine extensibility and I've looked through the others but can't see anything. Here is the error.


Sorry, I found it. There was a connector that was referencing it even though there was no agent...

<I've opened another ticket>

You seem to be confused about the nature of connectors. Connectors are not generic, but specific to the system they target. An agent is just the connection to that system and allows multiple connectors to use the same connection configuration. If you uninstalled a connector, you won't be able to use that connectors configuration.