0
Answered

Reasons for Upgrade?

Daniel Walters 1 month ago • updated by Matthew Davis 1 month ago 1

I have a customer on version 4 of Identity Broker and there's some interest in an upgrade. What is the current version of UnifyBroker? And what reasons are there to give them to upgrade from 4? Their main complaint is with the connector browsing and searching being unresponsive and ambiguous as to whether a search has loaded or no results have returned. Has there been work done on the search/browse for connectors? What else is good about the new version compared to 4?

Affected Versions:
Fixed by Version:

Answer

Answer
Answered

Hey Dan,

The current version of Identity Broker is 5.3.1.1.

For a complete list of high-level features since 4.0, please see this link:

https://voice.unifysolutions.net/knowledge-bases/7/articles/3058-unifybroker-release-notes

The UI has been changed to use a REST endpoint, and improvements made so there's no longer issues with the browsing and searching being unresponsive. 

The other main benefits of upgrading include:

  • using LDAP for data between IDB and MIM, which allows for faster data and more flexible MA configuration
  • Powershell adapter transformations
  • Auditing

Identity Broker 4.x is also out of support, so it would be in their best interests to upgrade. 5.3 will be supported until at least 03/2023.

Answer
Answered

Hey Dan,

The current version of Identity Broker is 5.3.1.1.

For a complete list of high-level features since 4.0, please see this link:

https://voice.unifysolutions.net/knowledge-bases/7/articles/3058-unifybroker-release-notes

The UI has been changed to use a REST endpoint, and improvements made so there's no longer issues with the browsing and searching being unresponsive. 

The other main benefits of upgrading include:

  • using LDAP for data between IDB and MIM, which allows for faster data and more flexible MA configuration
  • Powershell adapter transformations
  • Auditing

Identity Broker 4.x is also out of support, so it would be in their best interests to upgrade. 5.3 will be supported until at least 03/2023.