0
Answered

Error -2147467259: failed to create SQL database: UnifyIdentityBroker, error detail: unknown error.

Matthew Davis 5 months ago • updated by Adam van Vliet (Product Manager) 5 months ago 3

On installing UNIFYBroker with the database server being remote, the following is logged by the installer:

CreateDatabase:  Error 0x80004005: failed to create to database: 'UnifyIdentityBroker', error: unknown error
MSI (s) (2C!88) [11:12:22:654]: Product: UNIFYBroker/Service v5.3.1 RC1 -- Error 26201. Error -2147467259: failed to create SQL database: UnifyIdentityBroker, error detail: unknown error.

Error 26201. Error -2147467259: failed to create SQL database: UnifyIdentityBroker, error detail: unknown error.
CustomAction CreateDatabase returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Affected Versions:
Fixed by Version:

Answer

Answer

Thanks Adam.

Turns out the SQL Server Browser service was disabled by default from the SQL installer. Enabling and starting it resolved the issue.

Under review

Check the following (from https://voice.unifysolutions.net/knowledge-bases/7/articles/2920-identity-broker-installation-prerequisites):

  • Installer account permissions
  • If using a named instance, make sure you're setting it, otherwise blank
  • That SQL Server has appropriate permissions to create new database files
  • Named pipes is enabled
  • SQL Server Browser service is running
Answer

Thanks Adam.

Turns out the SQL Server Browser service was disabled by default from the SQL installer. Enabling and starting it resolved the issue.