0
Not a bug

The resource cannot be found - /Account/LogOn

Bob Bradley 2 years ago • updated by anonymous 2 years ago 8

Using

  • IdB service v4.1.5.5
  • IdB for Microsoft Active Directory 4.1.2.1
  • IdB for PeopleSoft Connector 4.1.0.0
  • IdB for FIM 4.0.0.3

* Note - About page incorrectly showing this: "UNIFY Identity Broker Management Studio, v0.0.5 Revision #5" ... can't explain this!

The following error is thrown when starting on the ABOUNT page (/About) and clicking on the Identity Btroker home page image to return to the dashboard.

The resource cannot be found. 
  Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly. 

 Requested URL: /Account/LogOn

The URL for this page is as follows:

http://localhost:8008/Account/LogOn?ReturnUrl=%2f

I am running IdB under IIS.  Navigating directly to the home page (by removing everything after the 8008 port number in the URL) also fails - only works after I put in a trailing ?, i.e.

http://localhost:8008/?

I am using a clean install of IdB 4.1, using the extensibility files from the (to be retired) existing v4.1.4 RTM version.

Affected Versions:
Fixed by Version:

Answer

Answer
Under review

Please try updating the authentication node in the web.config to:

<authentication mode="Windows" />

Answer
Under review

Please try updating the authentication node in the web.config to:

<authentication mode="Windows" />

Just updated authentication mode to windows, causing a restart of the website - and I noticed the same above warning in the app log again.  However the first problem seems to have been fixed.  Any idea why the revision shows as v0.0.5 Revision #5?

Yes, there was a bug in studio for the version.

I've been looking in the product installation documentation here for where I might have missed the step to change to Windows authentication mode, but I can't find anything.  I did already have Windows Authentication enabled via the IIS console - so what did I miss please?

What do you mean by "what did I miss"?

Yes, there was a bug in studio for the version.

Which has since been fixed.

OK I presumed the bug was regarding the incorrect version details - now you're saying there was another one regarding the Windows mode too.