0
Fixed

Identity Broker for Dynamics CRM - Annotations Connector filters and timeout

Ryan Crossingham 6 years ago in UNIFYBroker/Microsoft Dynamics CRM • updated by anonymous 3 years ago 15

Due to annotation fields, namely documentbody being HUGE after (i assume) base64 encode. We are currently experiencing timeouts on this connector. Are we able to add a configurable timeout on connectors? I believe its currently set for 2min..

Additionally - annotation contains every attachment available in Dynamics CRM. NZ Parli is only interested a mimetype of image/pjpeg and a subject of "Example" or contains "Exa". Are we able to add filters to the connectors?

Affected Versions:
Fixed by Version:

Error on timeout.

Change detection engine import all items for connector Dynamics CRM - Annotation Connector failed with reason The request channel timed out while waiting for a reply after 00:01:59.9949968. Increase the timeout value passed to the call to Request or increase the SendTimeout value on the Binding. The time allotted to this operation may have been a portion of a longer timeout.. Duration: 00:09:02.1028991 

Ryan Crossingham, I have added filters and timeout configuration to the connector. Let me know how it goes.

Thanks.

Hi Adam.

Few things happening off the back of this.

Issue 1#
If i set the filter as (without quotes): "subject Equal Security Photo"
Once i click Save - The filter is automatically changed to "subject Equal Security" .

Issue 2#
Even if the filter is set as above. The filter does not query for "subject Equal Security" so regardless of if the filter is being changed, the filter is not working as expected.

Thoughts?

James Booth - In order to get this going for you, i'm going to need to create both connectors WITHOUT filters.
This will create 80,000+ unwanted combined records. Obviously this not ideal...

If you want this done today this is what I need to do (and filter the connectors later).

Otherwise I will wait until Adam and I can filter these correctly.
Let me know your thoughts..

Hi Ryan, not sure how I stuffed up the filter, this is something I had tested, but missed that it hadn't worked.

The filter now loads and saves correctly, and I've added the option to OR the filters. Hopefully it's appropriate for you requirement.

Still no joy Adam.

The query is bringing back everything instead of just the filter i set

is there anything I can include to assist your troubleshoot?

I had made a mistake with the parsing of the filter. See v4.0.0.14. Sorry about that.

You're good mate.
Thanks for that - I'll give it a rumble!

Hi Adam.

How do i split two filters?

OR

subject Equal Security Photo
subject Equal Alternate Photo
subject Equal Security Photo : subject Equal Alternate Photo
subject Equal Security Photo, subject Equal Alternate Photo

Only a single filter currently works.
Example:

subject Equal Security Photo

Using

subject Equal Y
subject Equal X

Returns null value

Have you tried both settings for And Filters?

See v4.0.0.16, fixed up the and filters checkbox, as well as adding option to trace the request (if that fails).

Perfect!
You're the man Adam van Vliet!

Closed