0
Completed

Make installer more clear about authentication type

Peter Wass 7 years ago • updated by anonymous 4 years ago 11

I recieved the error:
Error -2147217843: failed to create SQL database:
Unify.IdentityBroker, error detail: unknown error.

Make the installer clearer regarding the different types of authentication.


dbinstall.png
Affected Versions:
Fixed by Version:

OK - if I specify the credentials it fails

I ran it specifying the credentials in the SQL as:
IDM\Administrator
<password>

It failed with the above error

I ran it with no credentials but logged in as IDM\Administrator and it worked.

Hi Peter,

What were the settings that you used in the database screen of the installer?

Thanks.

Server: localhost
Account: IDM\Administrator
Password: <password>

Everything else was left alone.

I also tried without 'localhost'

I can uninstall and get screenshots if you like

Is that account you mentioned above a Windows account? The account requirements for this particular section are a SQL Server account, not a Windows account. I tried to make this a little more clear with the label "SQL Account", could there be a way to make this more clear?

Thanks.

Ah
OK - the easiest way to make it obvious is to provide a header:
SQL Authentication------------

And / or have a checkbox "Use Windows Authentication" that, if unchecked, enables those two boxes for input.

I would also have a dialog when choosing Automatic (or doco) that specifies the SQL Creator rights.

Hi Peter,

I have been playing around with the installer and have come up with a potential solution. Please see dbinstall.png and let me know what you think.

Thanks.

Not bad - However its not the service account - its the currently logged in account. The text at the top of the screen also puts things in the wrong context. What I appear to be setting up here is the logon to create the database. I set the Broker Service Account elsewhere. If thats not what's happening then ignore me

I'd change 'Security Type:' to

Authentication: o Currently Logged In User (or Service account if I've got it arse backwards), o SQL Authentication

That is an accident, it is supposed to be the account that the installer is running as. The reason I labelled it as service account was from IDB-320, where it requires the service account, not the current account.

I'll fix up the other label too.

Thanks.

I have fixed those labels.

Please let me know following the next release.

Thanks.

Having used the installers several times since I can confirm the above. Closed.