0
Not a bug

Limited export run profiles not working

Eddie Kirkman 3 years ago in UNIFYBroker/Microsoft Identity Manager • updated by anonymous 3 years ago 1

With IDB5.0.3 configured for the Extensible Connectivity 2 Management Agent using the dll from the Unify Identity Broker for Microsoft FIM 5.0.3 installer.

Create an export run profile with an object limit.

Run the export run profile

All pending export objects are exported and when the run completes, the status message indicates that object limit was reached. See screenshots.

Affected Versions:
Fixed by Version:

Answer

Answer
Not a bug

Hi Eddie,


I've looked into this and it seems that the Generic LDAP MA (provided by Microsoft) has the same problem as well. The problem is that FIM gives the full collection of changes to the MA rather than only the number requested, and the number itself doesn't appear to be given on any parameters or configuration options either, so there is simply know way for the MA to know what the limit is.


I would suggest raising a bug with Microsoft about this (I can help with some of the technicalities if required). As a workaround, you can set the "Batch size (objects)" parameter to be the same as the "Number of Objects" parameter, in which case a single batch of the correct amount would be exported and then the agent would stop with "stopped-object-limit".

GOOD, I'M SATISFIED

Thanks. We will just make sure that the limited export run profiles are configured by batch size rather than object limit.

Satisfaction mark by Eddie Kirkman 3 years ago
Answer
Not a bug

Hi Eddie,


I've looked into this and it seems that the Generic LDAP MA (provided by Microsoft) has the same problem as well. The problem is that FIM gives the full collection of changes to the MA rather than only the number requested, and the number itself doesn't appear to be given on any parameters or configuration options either, so there is simply know way for the MA to know what the limit is.


I would suggest raising a bug with Microsoft about this (I can help with some of the technicalities if required). As a workaround, you can set the "Batch size (objects)" parameter to be the same as the "Number of Objects" parameter, in which case a single batch of the correct amount would be exported and then the agent would stop with "stopped-object-limit".