0
Fixed

Operation lists configured for EvB version 3.2.1.3 fail on first run after upgrade to 4.0.0.0

Bob Bradley 1 year ago • updated by anonymous 1 year ago 18

On running the EvB 4.0.0.0 scheduler for the first time for an upgraded 3.2.1.3 configuration, each operation with a MIM run profile began failing with the following error:

Operation faulted: Attempting to check for exports in non-existent management agent with id xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx - Please see the log viewer for more details. 
20170814,05:22:04,UNIFY MIM Event Broker,Operations,Error,"Operation Pending Export for Management Agent REDACTED with id REDACTED failed
in the operation list FIM Agent REDACTED with id REDACTED for the following reason. This is retry number 0:
Unify.Framework.UnifyConfigurationException: Attempting to check for exports in non-existent management agent with id REDACTED
   at Unify.Product.EventBroker.MIMAgent.ExportsPendingForManagementAgent(Guid managementAgentKey)
   at Unify.EventBroker.Agents.Audit.MIMAgentAuditingDecorator.ExportsPendingForManagementAgent(Guid managementAgentId)
   at Unify.Product.EventBroker.OutgoingPendingPlugIn.Check()
   at Unify.EventBroker.PlugIn.Audit.CheckOperationAuditingDecorator.Check()
   at Unify.Product.EventBroker.OperationListExecutorBase.RunCheck(ICheckOperationFactoryInformation checkOperation)",Normal

Answer

Answer
Fixed

Fixed from v4.0.1 onwards. For v4.0.0, please unzip Services.zip into the Services directory and restart the service.

Under review

Please refresh the agents from the auto-configuration page for the desired MIM Agent. Let me know if the issue reoccurs.

Still occurring after refresh Adam

... no MA run profile has run successfully since the upgrade

Were any errors returned to the UI following the refresh? The operation retrieves the MA's and run profiles and saves them for use elsewhere.

Please find the stored values collection file (I don't recall what the files is called) in isolated storage. It should be located under %LocalAppData%\IsolatedStorage.

No IsolatedStorage folder exists for the service account in question I'm afraid.  Any other ideas?

I've double checked the guid reported in the error message and it DOES (still) match the corresponding MA exactly

Hi Bob,

The storage file should actually be under C:\ProgramData, then a few levels deep from there there should be a file called EventBrokerStoredValues.xml. The error message 

Attempting to check for exports in non-existent management agent with id xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

is now actually incorrect and we need to fix it. As of v4, the id that it searches by should be our own internal ID that we track, so that if either the MA id or the MA name change, the id in the operation list configuration need not change. This means that the id in your operation list config (the managementAgentId attribute of the OutgoingPending element) should also match this internal id. Please refresh the MAs from the UI and then check this file to see what the "Key" field is corresponding to the MA, and if necessary, update the managementAgentId property in the operation list config.

Hi Bob,

I'm attaching Services.zip which should resolve this. As stated, the issue is to do with the presence of direct MA identifiers in the OutgoingPending operation configurations. This fix should allow the operation to run successfully with the legacy configuration, without requiring changes to config. Please try unzipping this and placing the DLLs into the Services directory, then restarting the service.

Thanks - the patch worked, but only for outgoing ... the incoming ones are failing for the same reason

·         The operation list FIM Agent Staff Incoming failed. Click here for details. 
  
·         The operation list FIM Agent Users and Groups Incoming failed. Click here for details.  ]
Management Agent: Staff - Run Profile: Delta Import and Delta Synchronisation 
1 of 1  Operation faulted: Management agent details with key 1d797a44-57fe-49a5-873c-1193e692f23a or run profile with key {010ba812-8e63-4cc3-b7c0-a0b645e023d6} not found. Refresh the affected MIM agent, or reconfigure the operation list with the correct management agent or run profile. - Please see the log viewer for more details.
Management Agent: Users and Groups - Run Profile: DI DS AS ONE 
1 of 1  Operation faulted: Management agent details with key 4fb4790b-4a02-46ca-9764-2d88f2d026f5 or run profile with key {c895662f-8f8e-4ee5-a5f8-0b2d3022cc05} not found. Refresh the affected MIM agent, or reconfigure the operation list with the correct management agent or run profile. - Please see the log viewer for more details.

XML from DEV:

EventBrokerStoredValues.DEV.xml

DEV exceptions:

Management agent details with key 00afcadc-a377-4a02-904b-f75061f06b87 or run profile with key {99225526-1aa8-4e35-af8a-55f4e43943fa} not found. Refresh the affected MIM agent, or reconfigure the operation list with the correct management agent or run profile. - Please see the log viewer for more details.  
Management Agent: Staff - Run Profile: Delta Import and Delta Synchronisation 1 of 1 Operation faulted: Management agent details with key c6944196-f1f1-4883-88c1-077fcdad823d or run profile with key {010ba812-8e63-4cc3-b7c0-a0b645e023d6} not found. Refresh the affected MIM agent, or reconfigure the operation list with the correct management agent or run profile. - Please see the log viewer for more details.

Hi Bob,

Please try updating Unify.EventBroker.PlugIn.RunProfile.dll and let me know if the issue persists.

That certainly worked thanks Curtis - will let this run today and give it some time to bed down.

Excellent, thanks for confirming.

Answer
Fixed

Fixed from v4.0.1 onwards. For v4.0.0, please unzip Services.zip into the Services directory and restart the service.

Curtis - an old problem now appears to be showing up - not sure if it is related, so just need you to check before I raise a new ticket ...

I have the AD agent service account configured as svcFIM_MA@dbb.local instead of dbb\svcFIM_MA, since this format is necessary to ensure that the listener works properly (as it is in PROD with v3.2.1.3).

Listen Operation - Live 
Active Directory Listen 

However with 4.0.0.0 and the same account configuration, I am now seeing this in both UAT and DEV (for both AD listeners and one of the ADLDS listeners):

Listen Operation - Faulted 
Active Directory Listen 

I have been able to get the UAT ADLDS listener working (no idea why), but not the others.  Am now playing with the new preferred server settings, but wondering if the guid issue is mucking it up?


Unrelated. Please raise a new ticket.