0
Completed

FIM Agent configuration

Shane Day (Chief Technology Officer) 7 years ago • updated by anonymous 3 years ago 5

While I'm sure this screen works, when I was first presented with it I had no idea what to do.

Clicking on a field gave me a description, but that was just taking a punt that's what I had to do.

Unsure why I should need to enter a server name when dealing with a local server, or even why I am even able to enter the server name.

In IE8, the width of the text input boxes is inconsistent, disconcertingly so.

Whether or not to use the below fields for database connection. Otherwise, enter a database connection string.

The above quote is nonsense, the description needs to make sense.

The full name of the server being connected to.

What name? It's nickname? This needs to be much more specific.

The name of this agent

This is not particularly helpful either - perhaps saying "The name used to refer to this agent in operations"

Connection string description should be more descriptive, perhaps "The ADO.NET connection string of the FIM/ILM database". Additionally, this text box should be disabled when using the other method.

The name of the FIM database server

Again, this should be more descriptive. What name? The host name? Does it also need to include the SQL instance name if not the default?

The name of the FIM database.

Why not have buttons that prefill this with the two common ones for FIM and ILM? I'm using ILM for this work, so I had to go and find out what the database name is.

I don't like the description of the SQL connection type, either. "Whether or not" is not really a good start to a description.

Again, using Windows authentcation, why can I put in credentials in?

While I'm sure this screen works, when I was first presented with it I had no idea what to do.

Clicking on a field gave me a description, but that was just taking a punt that's what I had to do.

Unsure why I should need to enter a server name when dealing with a local server, or even why I am even able to enter the server name.

In IE8, the width of the text input boxes is inconsistent, disconcertingly so.

Whether or not to use the below fields for database connection. Otherwise, enter a database connection string.

The above quote is nonsense, the description needs to make sense.

The full name of the server being connected to.

What name? It's nickname? This needs to be much more specific.

The name of this agent

This is not particularly helpful either - perhaps saying "The name used to refer to this agent in operations"

Connection string description should be more descriptive, perhaps "The ADO.NET connection string of the FIM/ILM database".

Additionally, this text box should be disabled when using the other method.

The name of the FIM database server

Again, this should be more descriptive. What name? The host name? Does it also need to include the SQL instance name if not the default?

The name of the FIM database.

Why not have buttons that prefill this with the two common ones for FIM and ILM? I'm using ILM for this work, so I had to go and find out what the database name is. For this version I've put the default database names in the tool tip.

I don't like the description of the SQL connection type, either. "Whether or not" is not really a good start to a description.

Again, using Windows authentcation, why can I put in credentials in?

Adam, it's just the IE8 textfield length issue left. Not sure what's causing it... could it not be applying styles to the non-password and password fields properly? Chrome does not have this problem.

IE uses different font for password fields.
Fixed using stylesheet.