0
Answered

Event Broker 3 FIM Portal WF Activity Not Available

Daniel Walters 7 years ago updated by anonymous 5 years ago 15

I've installed the FIM Event Broker FIM Portal WorkFlow by following the instructions and I've done an iisreset and restarted the FIM Service. The Activity Information Configuration appears in the Portal, it also appears in the GAC and the details of the AIC match the details in the GAC. The problem is that the activity doesn't appear in the Portal. What could be the problem here?

Tony, are you able to look into this one please?

Hi Daniel,

As discussed please confirm the IISRESET process was correctly performed.

Tried changing the assembly name in the AIC and back again then doing an IISRESET, still didn't appear in new action WF dialogue.

The version of Microsoft.ResourceManagement.dll is 4.1.2273.0

The assembly version of the reference used in the Event Broker portal workflow is pre-R2;

In the R2 machine i've been testing against, the version 4.1.3114.0 maintains a series of assembly redirects.

Would you be able to confirm that the following:

<runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
      <dependentAssembly>
        <assemblyIdentity name="FunctionLibrary" publicKeyToken="31bf3856ad364e35" culture="neutral" />
        <bindingRedirect oldVersion="4.0.0.0-4.65535.65535.65535" newVersion="4.1.2273.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.IdentityManagement.Activities" publicKeyToken="31bf3856ad364e35" culture="neutral" />
        <bindingRedirect oldVersion="4.0.0.0-4.65535.65535.65535" newVersion="4.1.2273.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.ResourceManagement.Automation" publicKeyToken="31bf3856ad364e35" culture="neutral" />
        <bindingRedirect oldVersion="4.0.0.0-4.65535.65535.65535" newVersion="4.1.2273.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.ResourceManagement" publicKeyToken="31bf3856ad364e35" culture="neutral" />
        <bindingRedirect oldVersion="4.0.0.0-4.65535.65535.65535" newVersion="4.1.2273.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.IdentityManagement.WFExtensionInterfaces" publicKeyToken="31bf3856ad364e35" culture="neutral" />
        <bindingRedirect oldVersion="4.0.0.0-4.65535.65535.65535" newVersion="4.1.2273.0" />
      </dependentAssembly>
    </assemblyBinding>
  </runtime>

Correctly resolves the Event Broker reference to that in use at your environemnt?

Thanks.

This didn't resolve it, Event Broker WF is still not appearing.

Email thread:

Dan,

It is not two instances of FIM. We have only one. Base setup is:

FIMDEVSS01

  • FIM Sync
  • FIM Service
    FIMDEVSER01
  • SharePoint
  • FIM Portal on top of SharePoint

Technically, we only need to install the activity library in FIM Service server. I have no idea why this environment requires the library in both servers.

AS you said, someone may play around with FIM setting/configuration …

Regards,
Huu

From: Daniel Walters
Sent: Thursday, 11 April 2013 4:01 PM
To: Huu Tran; Rizwan Ahmed; Paul Barratt; Sam Wang
Cc: Tony Sheehy
Subject: RE: FIM Event Broker Changes Activity

Face-palm didn’t realise we have two instances of FIM.

From: Huu Tran
Sent: Thursday, 11 April 2013 3:59 PM
To: Daniel Walters; Rizwan Ahmed; Paul Barratt; Sam Wang
Cc: Tony Sheehy
Subject: RE: FIM Event Broker Changes Activity

It happens to me before Dan.

I fixed it by installing the new library in both servers: FIMDEVSS01 and FIMDEVSER01.

No idea why but it just works.

Huu

From: Daniel Walters
Sent: Thursday, 11 April 2013 3:56 PM
To: Rizwan Ahmed; Paul Barratt; Huu Tran; Sam Wang
Cc: Tony Sheehy
Subject: FIM Event Broker Changes Activity

Hey Guys,

I’ve been trying to get this activity in the Portal but so far have been unsuccessful. Usually it’s simple, there’s a .exe that puts it in the GAC and a script to add the AIC to the Portal. The AIC appears in the Portal and it’s in the GAC with matching details but the activity doesn’t exist when I go to create a new WF. I went through a few tests with Tony and we found that if I create a new AIC with all the details from one of the existing custom Activities (doing the IISRESET and Service restart) the new dummy activity doesn’t appear either. Do either of you guys know why this might be? Has there been any changes made to the .exe.configs of FIM that may have this affect? Any Ideas?

Cheers,

Dan

We have two FIM servers so I need to install the activity to both for it to work. I was unaware of our whole architecture. Will sort this out today or next week, in the middle of testing other stuff right now.

To resolve current action.

Hi Daniel, do you have any update on this issue?

Never got around to re-installing correctly. Work on the DEECD project was halted so the issue is still open. I don't believe this is a problem in any way with evb, I just made some assumptions about the environment that were wrong.

No problem, I've updated the issue type so it no longer appears in our filter.

I'm finishing today so assigning to Rizwan as one of the project leads.

Project is close for the moment, assigning to Greg Scott to take action.