0
Answered

Need a more intuitive interface for the AD changes plug-in

Bob Bradley 8 years ago • updated by anonymous 3 years ago 3

Not really sure how to phrase this, but I spent several hours today (yes hours!) unsuccessfully configuring both of the AD changes plugins ... no matter what I tried, I was unable to get anything back but the following in the log files:

20110502,06:26:51,UNIFY Event Broker,Agent Engine,Warning,"The test of Agent UNIFYFIM AD (d3187109-fc0d-41f9-bd94-3a60a8757457) failed with message:
System.Runtime.InteropServices.COMException (0x80005000): Unknown error (0x80005000)
at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)
at System.DirectoryServices.DirectoryEntry.Bind()
at System.DirectoryServices.DirectoryEntry.get_SchemaEntry()
at Unify.Product.EventBroker.ADAgent.TestConnection()
at Unify.Product.EventBroker.AgentEngine.Notify(ITestAgentConnectionMessage message)",Normal

The exception stacks themselves are far from intuitive, and I know how difficult it is to get anything more meaningful from the System.DirectoryServices interfaces because I've been working with them myself for years. The problem is that EvB needs to be at least as easy (hopefully better) to work with as LDP.EXE (in c:\windows\adam), but at the moment you don't find out if there is something wrong until you run the scheduler, and then all you get is a generic message. The home page is helpful in identifying the general proximity of the problem, but in my case I found myself in trial-and-error mode. It shouldn't be that hard really ... if you're using a domain account you need a domain name as part of your credentials ... but try as I may I couldn't connect to AD, which should be one of the easiest plug-ins to configure (since it's by far the easiest MA to configure).

Run out of time to add more explanation ... way too tired and have to get up again in 4 hours ... but to get a feel for my pain today I would have really had to record my session . Perhaps this is the best way I can illustrate my problem ... by showing the different strings I tried in each of the following 3 fields alone (UNIFYFIM is the domain name):

Server: localhost; CENTRELINK-FIM; UNIFYFIM; CENTRELINK-FIM.unifyfim.unifytest.local
Username: administrator;unifyfim\administrator;unifyfim
administrator;administrator@unifyfim;administrator@unifyfim.unifytest.local
Authentication: Secure; Basic

All combinations and permutations of the above seemed to result in the same error.

Also, I had to resort to restarting the Event Broker service (not the scheduler, the main service) because I wasn't confident that a process hadn't hung on me, because the circular "processing" icon just seemed to persist for ever after an exception had occurred.

In summary, I think this needs more attention as it will definitely be the source of the most grief for any potential client if it's not as least as easy to use as the AD MA.

Also Bob,

The configuration for AD Sync is slightly different to the regular AD plugin. The differences have been highlighted in both the UI and the documentation.

No more work required - will revisit when next configuring these 2 plug-ins for the first time at the next site