0
Fixed

Service stops responding after adding blocked once off timing

Lindon Wass 7 years ago • updated by anonymous 3 years ago 6

After selecting the Exclude this time period on the selected days... under Schedules (with Start time 00:00:00, End time 23:59:59 and all Exclusion days selected) the CPU reached 100% usage and the interface stopped responding. This only seems to happen when the time is first created or the service is restarting. After a long period, the interface responds again and correctly displays that the timing should never run. Subsequent attempts to view the next run do not slow down.

It looks like this behaviour does not occur in Identity Broker v4.0.

Tony, as per my comments on EB-456, is this something that could be easily fixed in a few minutes or can we not even recreate it?

Instead of calculating the next run, if the timing meets these settings return DateTime.Max to force a never timing.

Moved to 3.2 to reflect Framework changes.

Migrated to Visual Studio Online.