0
Answered

Event Broker: Sorry, you do not have permission to perform this action.

Victor Maceda (NZ Parliament) 5 years ago • updated by Adam van Vliet (Product Manager) 3 months ago 8

When I login to the event broker I'm redirected to http://localhost:8080/Error/Unauthorized with an error message:
Sorry, you do not have permission to perform this action.

I tried the fim admin and the fim event broker service account and I'm still getting the error. I've also restarted the service and still I got the error. I've reinstall the program restarted the service and I still got the same error.

Currently, I'm stuck. Any help is appreciated


iis.png
self.png

Got this sorted. Found out where the problem is. Can you please close this issue

Received from Victor:

Go to C:\Program Files\UNIFY Solutions\Event Broker\Services\Extensibility\Unify.Product.EventBroker.EventBrokerPlugInKey.extensibility.config.xml

Make sure you have the following:

If self-hosted:

If hosted in IIS (specify the users who need access):

Restart Unify Event Broker Service.

Thank you Victor Maceda (NZ Parliament). I have created EB-642 to update our documentation.

Adam, can this now be closed?

Hi, I'm getting this exact error at ACT Health. The picture instructing what to do is a broken link. What do I need to do? It's IIS hosted. I already have Full Control over the mentioned file, is it something else?


It was the EventBrokerPlugInKey config file in \services\extensibility access control AD groups I had to be added to to fix this.

Please raise a ticket in Ivanti.

I found the fix as above. Do you still want a ticket?

Ah, misread your comment. All good, thanks.