0
Fixed

Creating a Schedule for "Don not run on the selected days..." issue

Shane Lim 7 years ago • updated by anonymous 3 years ago 4

The issue is that through the below sequence of action a Schedule cannot be created.

1 - Create an Operation List and leave it in disabled state.

2 - Add a Schedule with the following settings

  • Select "Do not run on the selected days..."
  • In the Days To Exclude - select all the 7 days
  • Click the "Create" button.

The follow error result: Every single day has been included as an exlusion period.

Let's say I changed my mind and decided not to use the "Do not run on the selected days..."
3 - Deselected the "Do not run on the selected days..."
4 - Click "Create" button

No Schedule is created and the same page for creating Schedule is presented. I cannot create any Schedule.

The cause of this issue is because the error with Every single day has been included as an exlusion period. is not resolved. Even-though the option is not longer selected the error is still being evaluated and halt the creation process. This is made mysterious because once the "Do not run on the selected days..." is not selected it collapse the display and thus the error is no longer visible.

Resolved - due to validation still being applied irrespective of whether the schedule Timing property had been selected.

I presumed that the fix will be available in the next version of Event Broker, after v3.0.0.1.

I presumed that the fix will be available in the next version of Event Broker, after v3.0.0.1.

This fix will be in the next version.