0
Fixed

Create and configuring ADDS MA Agent for Event Broker v3.0.0.1 result in error - System.Runtime.InteropServices.COMException (0x80005000):

Shane Lim 8 years ago • updated by anonymous 4 years ago 12

I have created ADDS MA with the following configuration:
Name: ADDS MA-AHG
Server: localhost
Username: FIM\Administrator
Password and Confirmpassword: xxxxx
Authentication: Secure

I have also tried Basic authentication.

(Note: The FIM\Administrator use is used to run the Event Broker service)

Both result in error:

5/2/2011 11:30:31 PM Warning
 UNIFY Event Broker Agent Engine The test of Agent ADDS MA-AHG (32c0ad55-b955-42c0-9194-fd73e2752fb7) failed with message:
System.Runtime.InteropServices.COMException (0x80005000): Unknown error (0x80005000)
at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)
at System.DirectoryServices.DirectoryEntry.Bind()
at System.DirectoryServices.DirectoryEntry.get_SchemaEntry()
at Unify.Product.EventBroker.ADAgent.TestConnection()
at Unify.Product.EventBroker.AgentEngine.Notify(ITestAgentConnectionMessage message) 


2011 11:31:30 PM Error
 UNIFY Event Broker Operations Operation c58cb9c6-0c81-4929-bb99-c49180754641 failed in operation list with id 9852408e-0606-44a7-81a2-8766d08e28ce for the following reason. This is retry number 0: System.Runtime.InteropServices.COMException (0x80005000): Unknown error (0x80005000)
at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)
at System.DirectoryServices.DirectoryEntry.Bind()
at System.DirectoryServices.DirectoryEntry.get_AdsObject()
at System.DirectoryServices.DirectorySearcher.FindAll(Boolean findMoreThanOne)
at System.DirectoryServices.DirectorySearcher.FindOne()
at Unify.Product.EventBroker.ADChangesPlugIn.GetChanges(DirectorySearcher searcher)
at Unify.Product.EventBroker.ADChangesPlugInBase.Check()
at Unify.Product.EventBroker.StandardOperationListExecutor.RunCheck(ICheckOperationFactoryInformation checkOperation) 

I could not find anything that I am obviously omitted based on the documentation at https://unifysolutions.jira.com/wiki/display/EB300/Active+Directory

Could someone please assist.

Hi Matt,

Can you please look at this tomorrow. Without knowing much about it, it's possible the problem may lie in the default authentication types provided. I believe Tony didn't take them from the previous version of Event Broker (where they'd be tested thoroughly), so I'd suggest starting there.

Hi Matthew,

I understand you and everyone is is totally snowed under.
Any help to progress this would be much appreciated.
I am keen to resolve this and get it working so that I can move on to other tasks.

Shane,

This is actually the issue I'm looking at at the moment. I will update you when I know more

Thanks Matthew,

I am assumming that others have successfully created and configured ADDS MA agent for ADDS on Windows 2008 R2, thus I am currious as to why I am encounterring this issue.

FYI - with Event Broker v2.2.3 I have been able to configured it to work with this instance of ADDS, albeit the configuration details is slightly different.

Hi Shane,

Why are you waiting on Matthew for this? Chances are there is a problem on our side as I said before, which means we'll be required to fix it and issue v3.0.0.2 - which may not be for a few days. If you've done all you can for testing with this version then you should continue on with your Professional Services work until we provide a new installer or prompt you for more information on an existing issue.

Hi Patrick,

Thanks you for the clarification. I am doing other work...

Regards.

Resolved some underlying issues with AD Agent configurations. AD Changes operation seems to be performing as expected. Assigned to Adam to continue further investigation into issues with AD Sync Changes

Matthew,

Please debug your solution and confirm that the EXACT path, username, password and Authentication types are coming through and being set as the code that I gave you.

Thanks.

Fixed remaining issues with the AD Sync operation, namely that the domain should be specified and not an OU path

Please confirm resolution in the next release

Confirmed creating ADDS Agent no longer result in the Bind error.